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ABSTRACT 

Timely access to right information has become more and more vital in every sphere of life and 

quick access to right information has become absolutely essential and also crucial to optimize 

the education and research output. The Online Union catalogue, digital repository and digital 

libraries are the new paradigms which have been taken up under ICT initiative to facilitate 

best services to researchers, teachers, students and extension professionals. The paper 

discusses about the attempts made by Indian Council of Agricultural Research (ICAR) to 

develop Union Catalogue of agricultural libraries (AgriCat) in partnership with OCLC, Ohio 

under “eGranth Project” funded by World Bank. The paper also discusses about tools, 

technologies, standards, software used in creating and developing "AgriCat” especially Batch 

uploading procedures. It sums up with the ongoing outcomes of the project and success stories 

including capacity building of the agricultural library professionals. 

 

KEYWORDS: NARS, ICAR, SAU, eGranth, OCLC, WorldCat, AgriCat, Union Catalog, 

Batchloading, Connexion, Koha. 

 

 

1. INTRODUCTION 
 

Information access is an area of research spanning over Informatics, Information Science, 

Computer Language, Information Technology, Computer Science and Library Science. Timely 

access to right information has become more and more vital in every sphere of life.  Quick 

access to right information has become absolutely essential and crucial to optimize the 

education and research output.  Therefore, the demand for fast access to right, authentic and 

credible information sources has become important and indispensable for any institution. 

 

In the era of Library 2.0 and 3.0, the paradigm of library services have become more user 

interactive and user driven. Maintaining a traditional form of library with hard copies of 

catalogues is becoming more difficult and outdated. Apart from being labour-intensive, it does 

not have enough appeal to attract users. Now a days no library can work in isolation and also 

cannot survive without taking advantage of sweeping changes taking place all around us. The 

Online Union catalogue, digital repository and digital libraries are the new paradigms which 

have been taken up under ICT initiative to facilitate researchers, teachers, students and 
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extension professionals. The services of libraries were static and one sided (non-interactive), 

but now services have been changed fundamentally over the past couple of decades into 

dynamic, interactive and virtual. The services being provided by computerized libraries are 

much timelier, active and accurate that brings improvements in research performance and 

effectiveness. New resources, services and technologies continue to emerge and creates new 

opportunities, new challenges for the library professionals and new expectations by users. 

 

Till the year 2000, the agricultural libraries were providing services and resources purely in 

traditional method and were characterized by: 

 

(i) Inadequacy in journals resources. 

(ii) Inadequacy of hardware and software. 

(iii) Non-availability of computerized in-house bibliographical databases. 

(iv) Conventional resource sharing methods. 

(v) Inadequate document delivery services. 

(vi) Need for ambient environment for the library users. 

(vii) Need for training of library professionals at different levels. 

 

National Agricultural Technology Project (NATP) of ICAR during 2002-2005 supported the 

libraries under sub-project entitled "Strengthening of Libraries and Networking under NARS” 

which was part of Organisational & Management reforms component of NATP funded by the 

World bank. The sub-project enabled the agricultural libraries of NARS to undertake 

automation, digitization, strengthening of ICT infrastructure, development of library websites 

and also improved capacity of agricultural library professionals. Basic internet connectivity of 

these libraries was also part of this project1. 

 

2. NATIONAL AGRICULTURAL RESEARCH SYSTEM - INDIA (NARS) 

 

It is one of the largest research/academic systems in the world with effective functioning in 

close association with agricultural education, research and extension systems. It has greatly 

contributed to the rapid growth of agriculture after Indian Independence. The research system 

includes approximately 30,000 researchers and more than 100,000 technically qualified staff 

actively engaged in research and education related to agriculture and allied fields. 
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Figure 1: National Agricultural Research System of India (NARS) 

(http://www.icar.org.in/files/ICAR-institutes-map.jpg) 

 

The present NARS comprises essentially two main streams, viz. the ICAR at the national level 

and the Agricultural Universities at the state level. Besides, several other agencies such as the 

Conventional/General Universities, Scientific Organizations, various Ministries/Departments 

and also Private or Voluntary Organizations participate directly or indirectly in research 

activities related to agriculture. 

 

ICAR is major agricultural scientific autonomous organization in the country and unique in 

having concurrent responsibility for research, education and extension under the Department 

of Agricultural Research and Education (DARE), Ministry of Agriculture, Government of 

India. It comprises of 49 ICAR’s Central Research Institutes including ICAR Head Quarters at 

Krishi Bhavan, New Delhi, 05 National Bureaus, 12 Project Directorates, 30 National Research 

Centres, 90 Coordinated Research Projects and 8 Trainers Training Centres, 531 Krishi Vigyan 

Kendras, 04 Deemed Universities  employing about 6000 scientists and students. It also support 

54 State Agricultural Universities (SAUs) and 1 Central Agricultural University in 

coordinating, guiding and managing research and education in agriculture. 

 

Good library and information services are an essential underpinning for research, just as they 

are for successful teaching and learning. Success in research, at both national and institutional 

levels, depends critically on the quality of the information services to which researchers have 

access2,3. 

 

3. eGRANTH 

 

A major initiative has been taken by ICAR through the project entitled “Strengthening of 

Digital Library and Information Management under NARS (eGranth)” under National 

Agricultural Innovation Project (NAIP) funded by World Bank4,5,6. 

 

http://www.icar.org.in/files/ICAR-institutes-map.jpg
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Figure 2: eGranth website 

 (http://www.egranth.ac.in) 

 

 

3.1 Mission of the Project 

 

(i) To create a network of Digital Library under NARS to foster creativity and free access 

to all users. 

(ii) Digital Library of selected institutes/universities with a free-to-read, searchable 

collection of rare books, institutional publications available to everyone over the 

Internet. 

(iii)To provide support for full text indexing and searching based on OCR technologies 

wherever possible. 

 

3.2 Objectives  

 

(i) To create combined Online Public Access Catalog (OPAC) of all 12 partner library 

resources with Online Computer Library Centre (OCLC) partnership. 

(ii) To digitize important institutional repositories including rare books and old journals 

and make them open access under NARS. 

(iii) To strengthen capacity building and information management system in all libraries of 

NARS. 

(iv) To implement open source ILMS Koha in 38 libraries to bring them on standard plat-

form for easy data sharing. 

 

3.3 Functions 

 

Duplication of bibliographical record creation can be avoided and saving of manpower is 

possible by pooling the efforts through common electronic protocols for sharing of resources 

e.g., Inter library loan among NARS libraries is the need of the hour which are reeling under 

financial crunch.  As a first step in realizing this mission, it was proposed to have Union 

Catalogue of 12 libraries under first objective of the eGranth. The union catalogue of the 

http://www.egranth.ac.in/
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following twelve libraries under NARS was taken up as a pilot project in partnership with 

Online Computer Library Center, Inc. (OCLC), Dublin, Ohio, USA. 

 

1) Indian Agricultural Research Institute (IARI), New Delhi. 

2) Directorate of Knowledge Management in Agriculture (ICAR Library), New Delhi. 

3) Acharya NG Ranga Agricultural University (ANGRAU), Hyderabad, A.P. 

4) Central Institute of Fisheries Education (CIFE), Mumbai. 

5) Ch. Charan Singh Haryana Agricultural University (CCSHAU), Hisar, Haryana 

6) CSK Himachal Pradesh Krishi Vishwavidyalaya (CSKHPKV), Palampur, Kangra, H.P. 

7) GB Pant University of Agriculture & Technology (GBPUAT), Pantnagar, Uttarakhand 

8) Indian Veterinary Research Institute (IVRI), Izatnagar, Bareilly, U.P. 

9) Mahatma Phule Krishi Vidyapeeth (MPKV), Rahuri, Maharashtra 

10) National Dairy Research Institute (NDRI), Karnal, Haryana 

11) Tamil Nadu Veterinary and Animal Sciences University (TanuVAS), Chennai, Tamil 

Nadu 

12) University of Agricultural Sciences, Bengaluru, Karnataka 

 

4. OCLC AND eGRANTH 

 

Online Computer Library Center, Inc. (OCLC), Dublin, Ohio, USA is a non-profit, 

membership based, computer library service and research organization dedicated to the public 

purpose of furthering access to the world's information and reducing information costs. OCLC 

and its 72,000 member libraries from 170 countries cooperatively produce and maintain 

WorldCat-the OCLC Online Union Catalog, the largest Online Public Access Catalog (OPAC) 

of 1.9 billion records in the world. 

 

All the original 12 partner libraries under eGranth project were using different Library 

Management Softwares with various legacy formats or variant MARC formats. In order to 

bring  the cataloguing information of all these 12 libraries to standard platform so that their 

holdings can be reflected in WorldCat; the cataloguing data available with these libraries was 

converted into standard MARC21 format and uploaded to OCLC through two methods; 

"Batch Uploading" and direct entry through "Connexion" which is a middleware used by 

OCLC7. 

 

5. BATCH UPLOADING 

 

 Batch Uploading is an automated offline service that OCLC uses to process large amounts of 

library records in various data formats to synchronize library holdings with WorldCat by: 

(i) Setting and/or cancelling holdings on WorldCat records. 

(ii) Adding original cataloguing records to WorldCat. 

(iii)Providing OCLC numbers for your local system records. 

(iv) Providing copies of OCLC-MARC records that match the records you send for loading 

into your local system. 

 

Batch uploading integrates our library’s holdings in WorldCat to accurately reflect our 

collection and make it visible to our patrons, other libraries, and users of the Web through 

OCLC services. To use Batch uploading, we have to order the type(s) of bibliographic batch 

upload project(s) we need. In the order, we also request the output we need from project and 

provide OCLC with information about the characteristics of our library’s records. Select a 
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Batch upload “Project Type and Output” and “Order a Batch upload Project” for details. Batch 

upload uses MARC-formatted records for processing but can also convert other types of data 

from our library, for the various project types. 

 

OCLC Batch upload is an easy, cost-effective way to add, update, and cancel large numbers of 

catalogue records and holdings information in WorldCat. Libraries use batch upload to include 

their holdings information on millions of WorldCat records and to add hundreds of thousands 

of unique, original records to WorldCat8. 

 

When we load our catalogue records into WorldCat, our library gains: 

(i) Greatly enhanced visibility on the web. 

(ii) Resource sharing capabilities. 

(iii) Management tools to help you plan your library operations effectively. 

(iv) Membership in a cooperative, worldwide library community. 

(v) A link between WorldCat, national or regional catalogues and your local catalogue. 

 

 Batch upload services give us the ability to match, merge, format and synchronize OCLC 

Control Numbers between our local system and WorldCat. Initial synchronization and ongoing 

maintenance of OCLC Control Numbers within our local system is necessary when 

implementing and using WorldCat Local and WorldCat Navigator. 

 

   The OCLC Control Number is a unique, sequentially assigned number associated with a record 

in WorldCat. The number is included in a WorldCat record when the record is created. “Batch 

upload” is not the same as “batch processing” in Connexion client.  “Batch upload” is the name 

of the service that OCLC performs for libraries. “Batch processing” in the Connexion client is 

a function that libraries can use themselves to process multiple records at a time using the 

“Batch” menu command: 

 

There are 3 options available for obtaining OCLC Control Numbers from Batch upload 

services: 

 

(i) The Cross Reference (XREF) Report: Used to match and merge the OCLC Control 

Numbers into the bibliographic records in your local system. 

(ii) Your records returned with the OCLC Control Number: Merges the matching 

OCLC Control Number back into the record that you send to OCLC for processing. 

(iii) Full OCLC-MARC records: A file of matching OCLC-MARC records-containing 

the OCLC Control Number-can be returned to your institution. 

 

5.1 Procedure of Batch uploading 

 

The following step-wise process has to be followed to batch upload our library catalog to 

WorldCat. As soon as you order a batchload project for bibliographic records or for local 

holdings records (LHRs) and you receive a confirmation email with your assigned project ID, 

you can send your library’s records to OCLC9. 

 

Step 1:  Create DATA file(s) containing your records: Export your library catalog to 

MARC21 format using your local library software in multiple files (one file may 

contain about 90,000 records or 100 MB size). 
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Use naming conventions as given: 

• Use alphanumeric characters only (no hyphens, dashes, or other non-alphanumeric            

characters). 

• Use the following required naming convention to match naming the corresponding 

LABEL file: 

          Type DATA.D followed by the current date in the format yymmdd. Eg DATA.D130815 

• If you submit multiple files, add the extension .FILE and number the files. 

              Example:   DATA.D130815.FILE1 

                            DATA.D130815.FILE2 

                            DATA.D130815.FILE3 

• If you ordered a one-time batch project and send multiple files: Add the additional 

extension .LAST to the name of the last file you send for your project. The .LAST 

extension signals Batch Services that you have sent all of your records. For bibliographic 

record projects, only then can OCLC complete your project and generate summary 

reporting. 

  Example:   DATA.D130815FILE10.LAST 

 

• If your project consists of only one file, do not include .FILE, but do include .LAST. 

 

In case you are not able to convert in MARC21 format, non-MARC formats such as Excel, 

Delimited Text file, CSV files can be sent but MARC21 is preferred for data integrity. 

 

 Step 2: Create a LABEL file for each DATA file 
 

• Open a new document in a text editor such as NotePad. 

• Type the five field labels listed in the table below. Press the <Spacebar> twice (to enter 2 

blank spaces), and then type the data. 

 

           Labels -  Data 

           DAT   -     Date the DATA file was compiled, in format yyyymmdd, followed by 000000.0, no 

spaces                                                                                                               

           RBF   -     Number of records in DATA file, no comma 

           DSN  -     DATA file name 

           ORS  -     OCLC institution symbol 

           FDI   -     OCLC-assigned project ID number (found in your order confirmation e-mail from   

                           Batchload Services) 

 

Follow these guidelines for creating the LABEL file: 

• Type all content in capital letters. 

• Do not add any other data or notes. 

• Spacing in the data is critical. Preferably, use a fixed length font, such as Courier New, 

rather than a variable-length font, so that you can clearly see and fix any spacing 

errors. 

 Eg: To change the font in Notepad, click Format>Font. In the Font list, click Courier-New. 

            • Press <Enter> to enter the next field. 

 

Step 3. Upload the DATA and LABEL files to OCLC PSWeb 
  

             Upload the Data file prepared in Step-1 and Label file prepared in Step-2 through the PSWeb 
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http://psw.oclc.org/. It may take some time for OCLC to upload records in WorldCat and send 

reports which you can download through PSWeb. 

 

 

6. CONNEXION 

 

Connexion is OCLC’s flagship cataloguing service, a powerful, flexible, easy to use, suite of 

tools with built-in access to WorldCat. Libraries use Connexion to create and edit quality 

bibliographic and authority records, to help users find the materials they need faster, and share 

records with the entire OCLC cooperative to the benefit of libraries around the world. By using 

"Connexion" one get more done by minimizing the time spent creating and maintaining 

catalogue records and increase cataloguing efficiency through cooperation and by using the 

latest cataloguing tools and techniques. Before entering the cataloguing information through 

"Connexion", set up hardware, software as per requirements, download, install, and start the 

Connexion client, Setup Connexion Client Worksheet, design a Worksheet template with 

required fields and login Connexion with authorised user ID and password. Before creating a 

new record, by any method, always search WorldCat for your item and search again before 

adding your record to WorldCat to prevent duplicate record, define a classification scheme, 

holding library code, and institution symbol, you can create a record from an existing record 

or from a workform, or you can import records from your local system. 

 

Derive a new record from an existing record 
    Retrieve a WorldCat record that closely matches, or is related to, the item you are cataloguing. 

Use it to derive a work form for a new record, add data and edit the record as needed to complete 

the record and then save it or add it to WorldCat. 

  

Create a record from a workform (AACR2 or RDA based template) 

  Create a Single Record by clicking as per nature of resource to be catalogued i.e. Books, 

Computer Files, Continuing Resources, Maps, Mixed Materials, Scores, Sound Recordings or 

Visual Materials, etc., add data and edit as needed to complete the record, and then save it or 

add it to WorldCat. To create a new record from an existing record, retrieve and view the full 

record, open the Edit list, and click Derive New Record. 

 

Import records 

Create records in your local system and import them into Connexion as workforms. 

 

Replace master records 

 

Replacing master bibliographic records in WorldCat requires a minimum authorization level of 

Full. 

 

(i) Log on and retrieve the WorldCat record you want to modify. 

(ii)  Optional - Click Action > Lock Master Record (<Alt><F8>). 

(iii)Add or edit data in the record. 

(iv) Click Action > Replace Record (<Alt><F10> or Action > Replace and Update Holdings 

(<Alt><F11>). 

Note: The system locks the record automatically before replacing, if not already locked, and 

then unlocks it when the action is completed. 

• If the record replaced is in the online save file, the system automatically deletes it unless you 

http://psw.oclc.org/
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re-save before you close it. 

 

6.1 Batch process searches and record actions 

 

    Enter WorldCat searches and/or mark records for actions in one or more local files to process 

all at once in a batch. 

 

(i) Click Batch > Enter Bibliographic Search Keys (<Alt><B><B>). 

(ii) In the Query box, enter a full syntax search as you would in the Command Line of the 

interactive Search WorldCat window. 

(iii) Click Add or press <Enter>. The search is added to the list. 

(iv) Repeat steps 2 and 3 to enter more searches. 

(v) Option: Import searches from a text file (*.txt). To prepare the text file, use a text editor 

such as  Notepad. Type each search in full syntax on a separate line. In the Enter 

Bibliographic Search  Keys window: Click Import and enter the path and file name. 

(vi) When finished, click Save. 

(vii) When ready, run batch processing. See Run batch processing. 

 

6.1.1 Set actions on records for batch processing 

 

(i) Save records you want to batch-process in a local save file. Log off if you are online. 

(ii)  Display a record or select records in the local file list, and then click one of the 

following actions on the Action menu: 

 

Delete Holdings, Produce, Replace, Submit for Review, Update Holdings, or Export.* 

Or to batch print labels, click File > Print Label(s).* 

Recommended limit: No more than 2,500 OCLC numbers per batch 

*Required: For batch Export and Print Label(s), you must set options in Tools > Options > 

Batch to prevent immediate export or print. 

(iii)When ready, run batch processing 
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Figure 3: Template of Workform through "Connexion" 

 

 

Remove actions from records marked for batch: 

Remove the Ready Status from records to remove them from batch processing: 

(i) Display a marked record or select marked records in a local save file list. 

(ii)  Click Action > Set Status (<Alt><Shift><S>). 

(iii)Under Remove ready status for batch, select one or more check boxes for action(s) you 

want to remove. 

(iv) Click OK or press <Enter>. 

 

 

6.1.2 Run batch processing 

 

The Connexion client automatically logs on to run batch processing. To run batch processing: 

 

(i) Click Batch > Process Batch (<Alt><B><P>). 

(ii)  Select the local file(s) containing searches and actions you want to process 

(iii)Under Process, click a check box to select searches, record actions, export, and/or label 

print for  processing. 

(iv) Select a processing order in the Bibliographic [and or Authorities] Process order list. 

(v) When ready, click OK or press <Enter>. Batch processing runs immediately 

 

6.1.3 Quick batch: Set or delete holdings by entering OCLC numbers 
 

Batch-process Update Holdings, Produce and Update Holdings, or Delete Holdings by entering 

only the OCLC numbers of records. You do not have to retrieve the records first before taking 
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these actions. 

 

    By using above two methodologies, i.e. "Batch uploading" and direct entry through 

"Connexion", the  eGranth has developed three layers of union catalogue named " WorldCat" 

‘AgriCat’ and "LocalCat" in partnership with OCLC. The OCLC follows MARC- 21 format 

as a tool of Union Catalogue contributed by library cataloguers worldwide. These MARC- 21 

format records are then downloaded into the libraries' local catalogue systems. This allows 

libraries worldwide to find and download records for materials they want to add to their local 

catalogue without having to go through the lengthy process of cataloguing them each 

individually. It remains the world's largest bibliographic database with more than 1.9 billion 

catalogued holdings. 

 

7. WORLDCAT DATABASE 

 

The AgriCat as a sub-group of WorldCat tool has been deployed in NARS for cataloguing and 

creating database. Internationally accepted protocols have been used e.g., Z39.50 is a client-

server protocol for searching and retrieving information from remote computer databases. It is 

covered by ANSI/NISO standard Z39.50, and ISO standard 23950. The standard's maintenance 

agency is the Library of Congress. The AgriCat group catalogue is available at 

http://www.egranth.ac.in/AgriCat.html or http://www.agricat.worldcat.org/ which can be 

accessed 24x7 basis and provide versatile search and retrieval facilities to share library 

resources. The search is available at three layers global search (Libraries Worldwide), group 

search (AgriCat libraries) and the individual library search (Local level). A user can also 

register and create his own mini library using the feature like MyList, MyWatch List, MySaved 

Searches for further use. On searching a library, one can see what has been recently added to 

the library and view it, an experience similar to visiting fresh arrivals section in a library.         

                               

 
Figure 4: AgriCat@WorldCat Interface 

(https://www.agricat.worldcat.org) 

 

8. AGRICAT (UNION CATALOGUE) 

 

 AgriCat is a union catalogue useful to all library users as well as librarians. AgriCat helps in 

locating and sharing materials among group of libraries. Duplication of efforts in record 

creation (cataloguing) is avoided by pooling the efforts through common electronic protocols. 

NARS has a very large collection of printed resources in agriculture and allied sciences, spread 

all over the country in different libraries of ICAR institutes and State Agricultural Universities. 

AgriCat being a common union catalogue of these valuable archives allows sharing and online 
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access to researchers, teachers and students and other stakeholders to which they would not 

otherwise have access. 

 

AgriCat may be used for resource sharing by article exchange and inter library loans, 

acquisition planning to economize the shrinking funds. Practically, AgriCat virtualizes the 

complete experience of physically visiting the library, searching through the catalogue, going 

to stacks/racks, taking out the desired book and browsing through it, before deciding to issue 

it. Sitting at your desk or in comfort of your home, you can do this by few clicks, using AgriCat. 

 

 
Figure 5: A View of AgriCat @ eGranth 

(http://egranth.ac.in/AgriCat.html) 

 

9. IMPLEMENTATION OF KOHA 

  

 To strengthen the digital library initiatives, more advanced Library Management Software, 

compliant to open international standards is necessary for easy data portability and data 

sharing. Koha is open source software which has been identified for implementation in the 

NARS libraries with expert support and intensive trainings. In-house capacity building has 

been part of the strategy. All further advanced library automation systems like RFID for 

automated library services can be built only on robust Library Management System compliant 

to international standards for data compatibility and portability. In NARS, 12 libraries have 

already adopted Koha and more are joining. Koha is a full featured Integrated Library 

Management System (ILMS), downloadable free under GNU General Public License, 

maintained by a dedicated team of software providers and library technology professionals 

from around the globe. You have freedom to modify the codes to adapt it to your local needs 

and redistribute it. Koha has robust Cataloguing, Circulation, Patrons, Search, Serials control, 

Acquisition, Reports and Administration modules along with utility Tools and OPAC. By 

adopting it, the customer becomes ‘joint stake holder’ in the product. 

 

 Encouraged by the success, the scope of the project has been extended to include following 
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26 more libraries under NARS bringing the total number to 38 libraries, to share their 

catalogues and modernise their Library Management System by adopting Koha following 

standard protocols. New partners libraries are: 

 

1. Bihar Agricultural University (BAU) 

2. Central Arid Zone Research Institute (CAZRI) 

3. Central Inland Fisheries Research Institute (CIFRI) 

4. Central Institute of Brackishwater Aquaculture (CIBA) 

5. Central Institute of Fisheries Technology (CIFT) 

6. Central Institute of Freshwater Aquaculture (CIFA) 

7. Central Plantation Crops Research Institute (CPCRI) 

8. Central Potato Research Institute (CPRI) 

9. Central Soil Salinity Research Institute (CSSRI) 

10. Karnataka Veterinary, Animal and Fisheries Sciences University (KVAFSU) 

11. Rajasthan University of Veterinary and Animal Science (RAJUVAS) 

12. Directorate of Oilseed Research (DOR) 

13. Indian Agricultural Statistics Research Institute (IASRI) 

14. Indira Gandhi Agricultural University (IGAU) 

15. Kerala Agricultural University (KAU) 

16. National Academy of Agricultural Research Management (NAARM) 

17. National Bureau of Soil Survey and Land Use Planning (NBSS-LUP) 

18. National Institute of Research on Jute and Allied Fibre Technology (NIRJAFT) 

19. National Research Centre for Litchi (NRCL) 

20. Navsari Agricultural University (NAU) 

21. Orissa University of Agriculture & Technology (OUAT) 

22. Project Directorate on Poultry (PDP) 

23. Swami Keshwanand Rajasthan Agricultural University (SKRAU) 

24. Tamil Nadu Agricultural University (TNAU) 

25. ICAR Research Complex for Eastern Region (ICAR-RCER) 

26. Indian Institute of Spices Research (IISR) 

 

10. CAPACITY BUILDING 

 

Capacity building is essential component of any initiatives aiming at bringing change in our 

working system. Many of agricultural library professionals have been trained by holding 

frequent workshops, trainings, National Conferences, online discussion group, email 

interactions, etc. Two major Conferences, Ten workshops and several trainings have been 

conducted in all the software tools and technologies for use in above developments. This 

initiative is continuing and many more such workshops/trainings are planned to give an 

exposure to all agricultural library professionals in India. 

 

11. CONCLUSION 

 

The NARS is a comprehensive source of knowledge in agriculture and allied sciences 

consisting of vast collection of rare and valuable books, reports, theses, surveys, statistical data, 

maps, bulletins, newsletters, journal back volumes and other documents held by libraries of 

different Agricultural Research Institutes and State Agricultural Universities spread all over the 

country. In order to provide online access to this valuable resource to researchers and scientists 

all over the world, it is necessary to have robust ILMS based on international standards for easy 
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sharing of metadata, Online Union Catalogue of participating libraries and a Digital Repository. 

Under ‘eGranth’ project, a Digital Repository named – ‘KrishiKosh’ (Fig. 6) has been created 

having about 10 million pages of valuable contents. Based on experience in library data 

handling, it was collectively decided that ILMS should follow common established standards, 

not decided by individual companies and software developers. Koha has been chosen and 

implemented in 12 libraries and is being further extended to 26 more libraries. Koha has been 

planned to be implemented in SaaS (Software as a Service) architecture, so that any library 

under NARS can use customised version of Koha for their library operations as internet service 

without bothering for maintenance of hardware and software at their libraries and concentrate 

on their core competencies in library science. The eGranth is a collaborative project which 

envisages strengthening of libraries by implementing data standards, standardized Integrated 

Library Management Software for smooth day to day operations and enhanced user experience, 

effortless cataloguing and OPAC for individual libraries, Union catalogue for sharing 

resources, Digital Repository including Electronic Theses & Dissertations (ETD) and enhanced 

capacity building into the system.  It aims to be a Gateway to Indian agricultural knowledge 

accessible over the Internet and sharing its research information with the rest of the world using 

latest Information and Communication Technologies10. 

 

 
 

Figure 6: KrishiKosh website (integrated platform of eGranth/NARS libraries) 

(http://krishikosh.egranth.ac.in) 
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